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Support Tait AVL Radio &

SmartTRAC Workstation Configuration
TECHNICAL NOTE Guide

1°t March 2006

Applicability Applies to anyone who is setting up an Automatic Vehicle Location (AVL)
system using Tait equipment and SmartTRAC tracking software.

1. Introduction

This application note contains information relevant to setting up a
SmartTRAC AVL package with equipment from Tait Electronics LTD. It is
broken into 3 sections. Section 1 deals with conventional installations,
section 2 deals with MPT1327 installations and section 3 deals with
components that are common to both Conventional and Trunked
MPT1327 versions of the SmartTRAC application. Below is an example of a
typical conventional AVL system using Tait TM8100 radios.
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2. Architecture

Tait Electronics Ltd

A typical AVL installation consists of

- SmartTRAC PC software Version 4.54.

- Base radio connected to a personal computer via a serial lead.

- Communications system (MPT1327 Trunked or conventional).

- Vehicle(s) fitted with an AVL capable Tait radio connected to a GPS
receiver.

The components differ slightly between Conventional (PMR) and MPT1327

Trunked system.

3. SmartTRAC Software Installation

To install SmartTRAC, insert the CD-ROM into your CD-Drive. The
installation process will start automatically. Follow the on screen prompts
until a screen labelled Setup Type is displayed. For most instances select
‘Single User Installation’.

When the Maplnfo installation starts you will be asked to fill in your user
details. When a prompt appears asking for a Serial number, enter any
number to proceed, as this field is not used.

Wait until the Setup Finished box is displayed and then restart your PC.

4. Conventional (PMR) installation

Table 1 shows typical Hardware and Software configurations for the base
radio equipment and table 3 provides the configuration for the remote (or
vehicle) radio. Only use this information as a guide as the requirements for
your system may differ slightly.

Mobile Base Radio Base Station
Radio Type Hardware Firmware
Version
T2010/2015 E;ge((jcv&ngl] I\Eggt’?{) Standard The system can
work without a
Fitted with T2000- base station
12020 A77 (CCDI Modem) | Standard (Simplex
Optionally fitted operation),
with TMAAO1-02 Standard. howlevglr for
(TM RS232 options Supported reliable
TM81xx board) or TMAAO1- above coverage, a base
05 (Options Version 2.04 | station such as
extender board) the Tait T800,
Optionally fitted Standard. TB7100 or
with TMAA01-02 Supported TB8000 range
TM825x (TM RS232 options above should be used.
board) or TMAAO1- | Version 1.04
05 (Options and 2.05 for
extender board) dual mode.
Table 1
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Configuring the 1. Install SmartTRAC as per section 3.
base radio 2. If required install the required hardware as detailed in table 1.
3. Program the radio (TM8xxx) or the T2000-A75 (T201x) or the T2000-
A77 (T2020) as detailed under ‘programming the base radio’ in this
section of the document.
4. Connect the radio to the power supply and antenna.
5. Connect the radio to the PC’s serial port. This is via either a standard
9- way RS232 serial cable (when the radio is fitted with a T2000-A75,
T2000-A77 or TMAAO1-02) or a custom 9 way male to 9 way female
when using the TM8105. Table 2 below shows the connection details
to the 3 possible serial connectors for the TM8xxx.

TM8xxx communication port

Description and pin
assignment for RJ45 TMAAO01-02 TM8xxx AUX TM8105
standard RS232 (Mic Port) (DB9) (DB15) DB9
(PC connection)

2 TXD (TX data line) MIC_TXD) | 2 (Serial_TXD) | 11 (AUX_TXD) | 2 (PRG_TXD)

3(
3 RXD (RX data line) 7 (MIC_RXD) | 3 (Serial_RXD) 3 (AUX_RXD) 4 PRG_RXD

5 GND 6 (AGND) 5 (Data_GND) 15 (AGND) 8 (AGND)
Table 2
Programming the Programming the T2000-A75 (T201x) and T2000-A77 (T2020)

base radio . .
1. After installing the T2000-A75 modem programmer onto your PC,

start the application via Start2>Programs—->Tait Programming
Applications>A75 modem programmer as shown in figure 1.

NOTE: The T2000-A75 programming application is used for programming
both the T2000-A75 and the T2000-A77.

w3
A Becessories

rﬁ Tait Programming Applications

Figure 1
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Connect a 9-way serial lead between the PC serial port to the 9-way
connector on the back of the T2000. Turn the T2000 on.

Program the T2000-A7x with the values shown in figure 2. If the
modem has not been programmed before, click “‘Send Escape’ and
wait until the application responds with an ‘OK’ message before
reading or programming the modem.

This will enable the programming of the modem when the
‘Transparent Mode Auto Start’ option has been previously enabled
(the factory default).

The value of ‘Lead in Delay for Transparent Mode’ and the ‘Data
ID’ (numerical characters only where the first 4 characters are 0000
and the last 4 characters are the unique Identity) of the radio are the
only parameters that may need to be changed.

If there is a long delay between the time that the base station keys up
and the receive signal is heard (often due to sub-tone decode) then
this value should be increased accordingly, otherwise the data
message will be clipped.

File Commport Help

— Programming Y alues

Transparent mode auto start [~

Trangparent mode bawd rate |12m vl
Ower the air Baud rate |12m vl

Command mode baud rate Igggn j
g
SOM Ack delaw time |-| oo mS (100 - 12000)

SO ' ait for ack time IE seconds (1-20]
Lead in delay for transparent mode |2DD ms [40 - 5100]

Paowser up channel |-|

Datall |uunnsnnu

Inhibit CTS [~
Inhibit RTS v
— Options
Fead | Send Ezcape | Frogram |
r Statug
Figure 2
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Programming the TM81xx

The Base TM81xx will need to be configured so that it has a unique data
identity, can send and receive SDM’s and that the supported GPS SDM
format is selected.

(Refer to figure 3)

1.

Under Data—> General select the Powerup State as ‘Command
Mode'.

In this same field select ‘Output SDMs Automatically’

) Specifications
[ Recsiver Moritaring
0 [Datg

. Selcall

[ Seleallldentity
{0 Fived Fomst Bu
f0 Free Fomat Burd

b0 Tore Settings
L0 Control Status
. DTMF
' 00 DTMF Signaling
. Two-Tone

. Hetworks
([ Basic Seftings
O Features
i [0 Phone Patch
-0 PTT Signaling

{0 Emergency

LoD Al

. Channel Setup

f 01 Charinels
[ Scan Giroups

[ Kep Settings

[ Ul Preferences

Figure 3

(Refer to figure 4)

3.

Under Data->Serial Communications select the required Baud rate.
This needs to be set to ‘9600 as this is the default setting of the serial
communication rate for SmartTRAC.

In this same field select the Data Port to be used to connect the radio
to your P.C.

0 Speciications
[0 Recsiver Moritoring
0 Data

. Selcall

0 Seleall Identity

#0 Fised Fomat By
b Free Fomat Bur
O Tone Settings
O Control Status
. DTMF
“ 01 DTMF Signaling
. Two-Tone
“ 0 TwoTone Optio
. MDC1200
* [0 MDC1200 Optio
. Networks
Lo Basic: Settings
i[O Fealures
i [] Phane Patch
O PTT Signaling
L Emergency

0 &lers
. Channel Setup
[ Channels

[ Key Settings
O Ul Prefersnces

Figure 4
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(Refer to figure 5)
5. Under the Data ->SDM tab, select SDM Enabled.

Choose a unique 8 digit Unit Data Identity (numerical characters
only where the first 4 characters are 0000 and the last 4 characters are
the unique Identity).

From the dropdown box for SDM format select ‘CCDI2 GPS'.

Enter in the channel information for your system.

Program the radio.

00~

Figure 5

Programming the TM825x

The Base TM825x will need to be configured so that it has a unique data
identity, can send and receive SDM’s and that the supported GPS SDM
format is selected.

(Refer to figure 6)

1. Under Global Features=>Data->General select the power-up state
as ‘Command Mode'.

2. In this same field select ‘Output SDMs Automatically’.

Figure 6
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(Refer to figure 7)

3. Under Data->Serial Communications select the required Command
Mode Baud Rate. This needs to be set to ‘9600’ as this is the default
setting of the serial communication rate for SmartTRAC.

4. In this same field select the CCDI UART port to be used to connect
the radio to your PC and select ‘CCDI Enabled’.

Figure 7

(Refer to figure 8)

5. Under the Data ->SDM tab, select 'SDM Enabled’.

Choose a unique 8 digit Unit Data Identity (numerical characters
only where the first 4 characters are 0000 and the last 4 characters are
the unique Identity).

7. From the dropdown box for GPS SDM Format select CCDI2 GPS.

8. Enter in the channel information for your system.

9. Program the radio.

Figure 8
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Configuring the

remote (or vehicle)

radio

Tait Electronics Ltd

1. If required, install the required hardware as detailed in table 3.

2. Program the radio (TM8xxx) or T2000-A7x (T2xxx) as detailed under
‘programming the vehicle (or remote radio)’ later in this section of
the document.

3. Connect the radio to the power supply and antenna in the vehicle.

4. Locate the GPS receiver where it has an uninterrupted view of the sky.
This is either on the roof of the vehicle (for the external GPS RX's -
T2005-A00 or TMAAO5-01) or on the rear parcel tray in the vehicle
(for internal GPS RX — T2003-A00).

5. Connect the GPS RX to the chosen radio port. Connections to the
radios may vary. Refer to table 4 for a detailed description of the
radios hardware connection with the Tait supported GPS receivers.

Note: Take special attention to the power supply requirements of the
selected GPS receiver.

Mobile Radio
Type

Hardware

Tait Supported
GPS Rx

Firmware Version

T2010/2015

Fitted with

T2000-A76

(AVL CCDI
modem)

T2003-A00 and
T2005-A00

Standard

T2020

Fitted with

T2000-A78

(AVL CCDI
modem)

T2003-A00 and
T2005-A00

Standard

TM81xx

Optionally
fitted with
TMAAO01-02
(TM RS232
options board
or TMAAO1-05
Options
extender board

T2003-A00 and
TMAAQ05-01

Standard. Supported
above Version 2.04

TM825x

Optionally
fitted with
TMAAO01-02
(TM RS232
options board
or TMAA01-05
Options
extender board

T2003-A00 and
TMAAOQ5-01

Standard. Supported
above Version 1.04
and 2.05 for dual
mode

Table 3
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Tait Radio GPS Interface Details

T2000 fitted TM8000 TM8000 using T630-400 (MDT)
with T2000-A76 15 way Aux a GPS connection
Tait Supported GPS Receiver or T2000-A78 connector TMAAO01-02 (RS232
Connection details (Conventional) (TTL Connection) (RS232 connection)
or T2000-A66 connection)
(Trunked). All
provide an
RS232
connection
9 way GPS GPS 9 way 15 way 9 way 9 way
T2003-A00 Drange | cable operation Drange | Signal | Drange Signal Drange | Signal | Drange Signal
plug wire desc skt Desc. skt Desc. skt Desc. skt Desc.
Internally pins colour i pins pins pins pins
mounted 2 White | GPS data in 2 RXD N/A N/A 2 RXD 2 RXD
5 volt GPS 3 Green dGPS RX 3 XD N/A N/A 3 XD 3 XD
RX ata out
35Volt
\ 2,5 supply
4 Red | +5V Supply 4 +SVOIt | \a N/A 4 Volt 4 not
supply supported
supply as
standard
5 Black GND 5 GND N/A N/A 5 GND 5 GND
+13.8
N/A N/A N/A N/A N/A N/A N/A N/A N/A 6 Volt
supply
9 way GPS GPS 9 way 9 way 9 way 9 way
T2005-A00 Drange | cable operation Drange | Signal | Drange Signal Drange | Signal | Drange Signal
adaptor | wire desc skt Desc. skt Desc. skt Desc. skt Desc.
Externally pins colour i pins pins pins pins
mounted 3 White | GPORX 3 RXD N/A N/A 3 RXD 2 RXD
13.8 volt GPS data out
RX 5 Black GND 5 GND N/A N/A 5 GND 3 TXD
5 Braid Shield 5 GND N/A N/A 5 GND 4 -
“(Connection 5 | Yellow | GP2remote | g GND N/A N/A 5 GND 5 GND
to the radio On/Off
is via the 6-40V 5+13.8 6413.8 +13.8
provided 6 Red | Unregulated 6 Volt N/A N/A 6 Volt 6 Volt
aDg:pi‘?)SMS supply supply supply supply
15 way GPS GPS 9 way 15 way 9 way 9 way
TMAAO05-01 | Drange | cable operation Drange | Signal | Drange Signal Drange | Signal | Drange Signal
adaptor | wire desc skt Desc skt Desc skt Desc skt Desc
Externally Pins colour i pins pins pins pins
mounted 3 White GPS RX N/A N/A 3 AUX_RXD N/A N/A N/A N/A
13.8 volt GPS data out
RX 1 Blue | P> ™ /A N/A 1| Ao | wa N/A /A N/A
4(Connection Black
to the radio 15 and GND N/A N/A 15 AGND N/A N/A N/A N/A
is via the Braid
b 51’;";2”;74 s| 15 | vellow Gpér:/eg;?te N/A N/A 15 AGND N/A N/A N/A N/A
adaptor) 6—40V
8 Red Unregulated N/A N/A 8 +13v8_SW N/A N/A N/A N/A
supply
Table 4

NOTE: All Tait radios can be pre-ordered ready for AVL operation with the required firmware and hardware pre-
installed. For mounting options please contact your local Tait representative for details.

! Requires a wire to be connected internally of the radio from pin 4 on DB9 to S14 Pin2 on the logic board

2 Requires fitting of R15. Refer to MMA-00012-02 (TM8000 Acc. Manual) section 3 circuit diagram for details
3 Requires a separate 5 Volt supply as not available from the MDT (T630-400)
* Internal wiring details and the RJ45 socket pin numbers of the RJ45 to DB9 adaptor have been ignored

> Requires a wire to be connected internally of the radio from pin 6 on DB to $14 Pin1 on the logic board

6 Requires fitting of R17. Refer to MMA-00012-02 (TM8000 Acc. Manual) section 3 circuit diagram for details
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Programming the
remote (or vehicle)
radio

Tait Electronics Ltd

Programming the T2000-A76 (T201x) and T2000-A78 (T2020)

Connect a 9-way serial lead from the PC communications port into
DB9 of the T2000-A76/A78 connector at the rear of the T2000.

2. Ensure that pins 4 and 6 of the 9-way lead are isolated to prevent the
power feed from the radio causing possible damage to the PC serial
port.

3. Power up the T2000.

4. Program the T2000-A76/A78 using the ‘AVL programming’ tool (see
figure 9). A description of each field of the programming tool follows
on from figure 9.

5. Program the T2000 (using the T2000 PGM tool) for the required
operating frequencies and sub tones that you wish to use. Specific
programming of the T2000 for operation with the T2000-A76/A78 is
not required.

i AvL Programming Software Yersion 23034210 [_ O] =]

Eile Radio Internst Help

Di|d| &) i+ & 7

rAVL =
AVL FLAGS AVL Parameters
BardiED 4800 =l | Report Delay Time s
WV
BULE i LeacHnDeley o m
On-dir Baud Rate 1200 -
Tone Blank i~ Pawer-Up Channel 1
Au Cantrol Inhibit r
Radio 1D 0000200
Emergency Enable r
Emergency 441 Report Count [C
PTT ANI Farmat =
Emergeney AYL report Period s
= -
Grop Poll Idlie Delay Time 5000 ms
AL Despatcher Address O000R000
Print Help I
L=
Status Bar [Min Value - 100 [ Value - 25500 [StepWalue - 100 4
Figure 9

(Field descriptions - refer to figure 9)

10.

11.

Baud Rate: specifies the baud rate between the A76/A78 and the GPS
receiver. Default setting is 4800 Baud.

PTT ANI: If this box is checked, an AVL string will be sent each time
the PTT is pressed/released.

On-Air Board Rate: specifies the over-air data rate. This can either be
1200 or 2400 and must match the programming of the base radio.
Tone Blank: If this option is checked, the receiving audio will be
muted when AVL data is active on the channel.

Aux Control Inhibit: Not used for SmartTRAC

Emergency Enable: Enables an emergency AVL poll to be sent when
pin 7 of the T2000-A76/A78 9-way is grounded.

PTT ANI Format: If this option and the PTT ANI option are checked,
an AVL string will be sent on PTT release. If this option is un-checked,
an AVL string will be sent on PTT press only.

AVL Report Delay Time: the time between an individual poll request
is received and a response is sent.

Lead in Delay: This is the length of time the radio transmits before
sending data. This value should be increased if there is a significant
delay through the repeater system.

Power Up Channel: if the radio has been enabled for BCD channel
change, a default power up channel can be specified.

Radio ID: this should be unique for each vehicle and needs to be 8
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digits long (numerical characters only where the first 4 characters are
0000 and the last 4 characters are the unique Identity). This is the
number that SmartTRAC uses to poll the remote radio.

12. Emergency AVL Report Count: specifies how many emergency AVL
reports are sent on the activation (Pull to GND) of pin 7.

13. Emergency AVL Report Period: specifies the time before each report
is sent.

14. Group Poll Idle Delay Time: Not used for SmartTRAC.

15. AVL Despatcher Address: should match the identity programmed
into the A75/A77 base radio. This is the identity of the radio to where
the AVL response will be sent.

Programming the TM81xx remote/vehicle radio

(Refer to figure 3)

1. Under Data->General select the Power-up State as ‘Command
Mode'.

(Refer to Figure 10)

Under the Data=>SDM tab, select ‘'SDM Enabled’.

Choose a unigue 8 digit Unit Data Identity for this radio (numerical

characters only where the first 4 characters are 0000 and the last 4

characters are the unique Identity) i.e. different to the base radio and

any other radio in your fleet. (00008001 was used for this example).
4. For the GPS SDM format select ‘CCDI2 GPS'.

Ele Est Hado Ioch Heo
FHl & 4 T Rk B OH

Fadn Model THE100
Pechvabeici [0
el Gonerd| Sed Communicaions | AF Modens  50M | GP3 | Customer Datn |
I \.ri'.\l:.ﬂm A SDMy
'50M Enatled
Urk Data lgeritty [o0CEm
s SDMFomat [co0iGrs 7]
“"‘"‘"‘u ’ SOM Bulles Qverwaite [
TwworTore Dption:
MDC1200
MOC1200 Dptisns Tood SOMs Doy
"m:‘:mw__ It Wi SOM Fomcemved [
SOM Caller I
Phore Patch
PTT Signaling Tranamit SDM Auto Acknowledgement [
Emevgancy
Channed Sl
- """;'."l.. Rreceive SUM Auln Acknowedganerd [~
., : [—
Diatabare Vession: 0003
Figure 10
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(Refer to figure 11)

5.
6.

10.
11.

12.

13.

14.

Under the Data—>GPS tab select GPS Position Reporting Enabled.
Enter in a Connection Time Out value. This is the time the radio
allows before sending back the response ‘GPS not operational’ if
there is no data being received from the GPS RX.

Insert the data identity of the base radio in the Dispatcher Address
field.

Select the serial port of the radio that will be used to connect to the
GPS receiver (It must be different to the Data Port)

Select the required baud rate of the GPS RX (Usually 4800 for most
GPS receivers).

Enter in a Poll Response Delay Time if required.

The GPS Lead-In Delay field is used to set a ‘Lead in Delay’, to
overcome delays encountered when operating through a repeater,
before the SDM response is transmitted.

Select whether you want the poll response from this radio to go out
on the current or another dedicated channel set in the channel setup
field>Poll Response Channel Type field

The operating parameters of the alarm (When Activated via a GPIO on
the AUX connector) are set within the alarm field. This field sets how
many GPS Position reports are sent out and at what interval during an
alarm activation.

Program the radio for operation on the required frequency(s).

s [t Bado Tosk Heb
SRS 7T me R O BE R

Padc Model ThEI00
Spechcabons
Tleceiver Moriing EE
Ex" General| Sevial Commnicaionn | I Modema| SDM. 685 | Customes Dita |
st e Geresal Channel Senp

GPS Poston Reporting Enabled 7
Connechon Tme Dut [0
Dispatches Addess || TITEIEN
Sl Conmurications st oo
Grofonfam 5] Calout Intereal [20
bodae 100 7] Masmm Numper of Cakoums [5

RE Mogems Emergency
Pl Herane Delay Time [ 220 Eend Posion on £ Cold -

8% Lol Py [1205

Figure 11
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Programming the TM82xx remote/vehicle radio

(Refer to figure 6)

1. Under Global Features->Data—> General select the Power-up State
as "Command Mode’.

(Refer to figure 12)

2. Under the Data=>SDM tab, select ‘SDM Enabled’.

Choose a unique 8 digit Unit Data Identity for this radio (numerical

characters only where the first 4 characters are 0000 and the last 4

characters are the unique Identity) i.e. different to the base radio and

any other radio in your fleet. (00008001 was used for this example).
4. For the GPS SDM format select ‘CCDI2 GPS'.
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Figure 12

(Refer to Figure 13)

5. Under the Data->GPS tab select ‘GPS Position Reporting Enabled’

6. Enter in a ‘Connection Time Out’ value. This is the time the radio
allows before sending back the response ‘GPS not operational’ if
there is no data being received from the GPS RX.

7. Insert the 8 digit data identity of the base radio in the ‘Dispatcher
Address’ field.

8. Select the serial port of the radio that will be used to connect to the
GPS receiver (It must be different to the Data Port)

9. Select the required baud rate of the GPS RX (Usually 4800 for most
GPS receivers).

10. Enter in a 'Poll Response Delay Time' if required.

11. The GPS lead-in delay field is used to set a ‘Lead in Delay’, to
overcome delays encountered when operating through a Repeater,
before the SDM response is transmitted.

12. Select whether you want the poll response from this radio to go out
on the current or another dedicated channel in the ‘Channel Setup’
field.

13. The operating parameters of the alarm (When Activated via a GPIO on
the AUX connector) are set within the Alarm Field. This field sets how
many GPS Position reports are sent out and at what interval during an
alarm activation.

14. Program the radio for operation on the required frequency(s).
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What follows is a brief instruction on how to add a vehicle in SmartTRAC
version 4.54 that will enable you to poll conventional radios. For details on
the communication setup for SmartTRAC please refer to section 6 at the
end of this document. For a more detailed description on SmartTRAC and
it's components refer to the ‘SmartTRAC workstation user reference

manual’.

Adding Mobile Units to SmartTRAC

1. To enter a new vehicle, open SmartTRAC under

Start->Programs->SmartTRAC->SmartTRAC explorer.
Right click in the vehicles list window and choose ‘New Mobile Unit’

N

3. A properties box will appear with different options as shown in figure

14.

Details Tab

(Refer to figure 14)

1. Click on each of the following fields and then enter the required
information:

- Type: car, truck, van etc. The units will be grouped according to
their type in the filter window

- ID: any ID that is used for the vehicle. This field is not compulsory

- Name: this will be displayed next to the vehicle
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Style Tab

(Refer to figure 15)
1. The Icon, colour, size and track of the vehicle can all be changed

according to user preference within this field
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Figure 15
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ALC Tab

(Refer to figure 16)

This tab is used to configure how often the remote/vehicle radio is polled

by SmartTRAC and sets the identity. In this example there are only 2 fields

that need set:

1. Base: determines the automatic polling rate. In this example the
vehicle will be polled automatically every 15 minutes and a
latitude/longitude placed in the database. Limits are often set by the
network providers for the minimum value of automatic poll duration.

2. Unit number: this is the number that was programmed into the
T2000-A76/A78 and the remote/vehicle TM8xxx. This will be unique
for every Vehicle.

NOTE: Only 4 numerical numbers for the ‘Unit #' are supported in
SmartTRAC. The first 4 zeros of the radio units ID’s are therefore dropped
off for compatibility in SmartTRAC.

=
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Figure 16
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5. MPT1327 Trunked installation

Table 5 shows typical Hardware and Software requirements for the base
radios to operate an AVL system on a MPT1327 network. The remote (or
vehicle) radio equipment is detailed in table 6. Only use this information as
a guide as the requirements for your system may differ slightly.

. Base Radio Base Station
Mobile -
Radio Type | Hardware Firmware
Version
Fitted with
T203x T2000-A66 Standard
Fitted with
T2040 T2000-A66 Standard
Standard for
TMS8255. The system
TM8&250 requires a
. requires an MPT1327
Optionally optional Trunked
TMAAO01-02 . work
(TMASO011) if :
(TM RS232 .
TM825x . upgrading to
options board MPT1327
or TMAAQ1-05 .
; operation.
Options
MAP27
extender board )
operation
supported
above Version
2.05
Table 5
Configuring the 1. Install SmartTRAC as per section 3.
base radio 2. If required install the hardware as detailed in table 5.
3. Install an SFE key if required for MPT1327 operation on the TM8250.
4. Program the radio as detailed under ‘programming the base radio’
in this section of the document.
5. Connect the radio to the power supply and antenna.
6. Connect the GPS RX to the chosen radio port. Connections to the

radios may vary. Refer to table 4 for a detailed description of the
radios hardware connection with the Tait supplied GPS receivers.

Note: Take special attention to the power supply requirements of the
selected GPS receiver.

Programming the Programming the T203x and T2040
base radio .

(Refer to figure 17)

1. Start the T2000 ‘Trunked Application’ under Program Files> Tait
Applications>T2000->Trunked Application. This application is
used to program all T2000 MPT1327 Trunked radios.

2. Select the model type of your radio in the ‘Radio Type’ toolbar near
the top of the screen. This application note will use the T2040 radio as
an example. However the T203x radio settings are the same.

3. Enter in the details that will enable the radio to work on your network

4. Enable "MAP 27’ located in the specifications page.
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Figure 17

(Refer to figure 18)

5. The parameters of the CCI (Computer Controlled Interface) need to be
configured located in the CCI Setup page. Select the type of UIM
(UART Interface Module) that is fitted to the radio. ‘Single port’ is a
T2000-A66 (single port UART).

6. The setting of the Baud rate needs to be set to *9600’. This is the
default setting of the serial communication rate for SmartTRAC.

Figure 18
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(Refer to figure 19)

7. Under Call Options ensure that ‘Data Calls' is selected. This field sets
whether the user may set up data calls such as short data messages
(SDMs) over a traffic channel.

A
& m

A

=
|

- EkE e mm
L1 L L

Figure 19

(Refer to figure 20)

8. Ensure that ‘Short Data Messages’ and ‘Tait Data Protocol’ under
Data Parameters are selected. The default values within these fields
will suit most networks.

Figure 20
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(Refer to figure 21)

9.

10.
11.
12.

Check with the customer whether or not the radio should make a
sound (beep) when a GPS poll is made to the vehicle.

If this is not required then ensure that in the Audible interface field
under Interface options of the radio file that Tone On Speech Calls
is ‘enabled’ and ALL of the other tone alert fields are disabled.

s
-
L -
r
r
r
3
r
r
r
r
r

Figure 21

Enter the required details for your network.

The radio can now be programmed.

The T2000 MPT1327 Trunked radio is now ready for operation as the
'AVL base radio’.
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Programming the TM825x

As with the T2000 MPT1327 radio the TM825x MPT1327 radio will also

communicate with the P.C running SmartTRAC using the MAP27 protocol

only. In this mode CCDI control is not available.

(Refer to figure 22)

1. Under Global Features>Data->Serial Communications ‘unselect’
the CCDI Enabled box.

e V1107 FN Wes 5.mi2p - TMEZ00 Pyogramming Appleation [21.0.0)

Figure 22

(Refer to Figure 23)
1. Under Global Features->Data—>GPS ‘select’ the MAP27 Enabled
box.

2. Set the MAP27 Port to the required communications port.

3. Set the Baud Rate to 9600, which is the default setting of the serial
communication rate for SmartTRAC.

4. For full MAP27 communications set the Link Layer Type to ‘full’.

Telephone:+64-3-357-9991 TN-1063-AN-d.doc
support@taitworld.com
http://support.taitworld.com Date of Print: 01/03/06 Page 22 of 30



Tait Confidential

Configuring the
remote (or vehicle)
radio when either a
GPS or T630-400

Tait Electronics Ltd

M abesimDal P CallTesl Mer\Sample Wes rom AGUATMEZ00 VHE Oren V11,07 FN Ves 5mil2y =lslx
e B fade Feoues Lok Heb

D@ & & (KT Fado fifesd @ioogme B P

Psdio Mode T

Diata

Genera| Seral Commurications | NP Misdems | sobe | 6Ps [ mazz ]

MAFZ] Erbiod ¥

mrmp, vl

B Rate [0 -]

Lk Lages Ty [t =]

Didnbien Vistion D016, Ltk ckon: Dipmemd b TMEZ00 VHF Deon V1 107 PN Ve 50800

Figure 23

If required install the required hardware as detailed in table 6
Program the radio as detailed under ‘programming the vehicle’ (or
vehicle radio) in this section of the document.

Connect the radio to the power supply and antenna in the vehicle.
Locate the GPS receiver where it has an uninterrupted view of the sky.

MDT is directly
connected to the

This is either on the roof of the vehicle (for the external GPS RX's -
T2005-A00 or TMAAO5-01) or on the rear parcel tray in the vehicle
(for internal GPS RX — T2003-A00).

radio 5. Connect the GPS RX to the chosen Tait port. Connections to the
radios may vary. Refer to table 4 for a detailed description of the
radios hardware connection and Tait supplied GPS receivers.
NOTE: Currently the TM825x does not support GPS operation (Direct
connect) when operating in Trunked mode. This application note will be
updated with the instructions on how to configure the radio once this
feature has been implemented in the firmware.
Mobile Radio Tait Compatible - Firmware Version -
Hardware Connecting to a GPS Connection to a
Type GPS Rx )
Receiver T630-400 MDT
Fitted with
T2003-A00 and .
T203x T2000-A66 T2005-A00 Direct connect Standard
Fitted with T2003-A00 and .
T2040 T2000-A66 T2005-A00 Direct connect Standard
Optionally
fitted with
TMAAD1-02 Currently does not support
(TM RS232 di . :
options T2003-A00 and |re§t connection of a GPS
TM825x RXin MPT mode. MAP27 Standard
board or TMAADS-01 operation supported above
TMAA01-05 P PP
. Version 2.05
Options
extender
board
Table 6
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Programming the T203x and T2040

The programming of the remote (or vehicle) T203x and T2040 is the same
as the base radio. The port settings are encoded in the Direct Connect
firmware fitted to the radio.

If a T630-400 MDT (Mobile dispatcher terminal) is to be used with the
remote radio then standard firmware will be fitted to the radio and the
GPS receiver is fitted to the MDT. The MDT will communicate with the
radio using MAP27. The programmable settings of the radio are the same
as the base radio. Refer to the Programming the base radio section for
details.

Programming the TM825x

As the TM825x currently does not support GPS operation (Direct connect)
when operating in Trunked mode The programming of the TM825x
remote radio is for operation with a T630-400 MDT. The programming for
the operation with an MDT is the same as the base radio detailed in the
‘Programming the base radio’ earlier in this section. This application
note will be updated with the programming details for direct connect
operation once this feature has been implemented in the firmware.

The addition of the vehicle details to operate on a MPT1327 Trunked
network is the same as that for the conventional described in section
'SmartTRAC basic conventional configuration’. The only exception is
the ALC field:

(Refer to figure 24)

1. In the ALC field of the properties box enter in the MPT1327 prefix
and ident number for the radio unit. The radio used in this example
has a MPT1343 numbering of:

- Number prefix = 201
- Fleet number = 2100
- Unit number = 623

The MPT1327 equivalent is:
- Prefix=1
- ldent =623
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6. SmartTRAC features

Connecting the Base
Radio to the PC

Connect the base radio to a spare serial COM port on the PC using the
9-way cable supplied. The supplied cable is a standard computer 9 way
male to 9 way female with 1-1 wiring.

Once the radio is connected and switched on ensure that, for MPT
1327, the radio has network service.

Place a call on the radio to ensure that the received audio at the
remote radio is clear.

To specify which COM port the base radio is connected to choose
Tools>Communications Properties in the SmartTRAC window. A
communications properties box will be displayed as shown in figure
25.

' Communication Properties x|
— Chanrnel
| 0: Radio #1 =l
( Archive T b eg Queues T Advanced
Connect T Radio T Seszion
Pratocal | TAIT: GPS + MDT [55T) =l
Connection Typpe: IDirect Connect [RS5-232) j
Connect Yia: IEEIM'I: j

Cancel Apply

Figure 25

For conventional systems, the protocol within this window must be set
to TAIT:GPS only (conventional)

For MPT1327 Trunking systems, the protocol can be set to either:

- TAIT: GPS only (SST) for polling on the control channel

- TAIT: GPS only (NPD) for polling on the traffic channel

When Tools=> Communications Properties is selected the
SmartTRAC server will also start running. The SmartTRAC server must
ALWAYS be running in the background to process poll requests. An
icon will appear in the toolbar if communication to the base radio fails
as shown in figure 26.
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12056 pam,

Figure 26

8. Choose the COM port that the base radio is connected to and select
‘Connect Now’ under Tools in the toolbar of the explorer window. If
the operation is successful a system tray icon (bottom right hand side
of the screen) will appear then disappear. You are now ready to poll
vehicles.

9. If the operation was unsuccessful check that:

- Your radio is turned on

- The programming information and firmware versions are correct

- The serial cable is connected between the UART fitted to the base
radio and the correct COM port on the PC.

Once the COM port has been set up it will not need to be done again,
however the SmartTRAC server will always need to be running each time
SmartTRAC is started. This is achieved by selecting Tools=>Connect Now.

SmartTRAC uses MaplInfo format maps. Any MaplInfo workspace with a
‘.wor’ extension can be opened by either selecting File>Open and
selecting the workspace from SmartTRAC or by double clicking the
workspace from windows explorer. SmartTRAC will start automatically.

If SmartTRAC is running on a stand alone PC, it is a good idea to add the
map workspace (.wor) and SmartTRAC server to the windows StartUp
menu. This will automatically open the map and run the server whenever
the PC is restarted.

First find the directory where SmartTRAC was installed (usually c:\program
files\SmartTRAC) and add the file DbLink.exe to windows StartUp.

Do the same for the workspace of the map you are using.

To find information on adding programs to windows StartUp, please
consult Windows Help.

Telephone:+64-3-357-9991
support@taitworld.com
http://support.taitworld.com

TN-1063-AN-d.doc

Date of Print: 01/03/06 Page 27 of 30



Tait Confidential

Housekeeping -
Archiving the
database

Tait Electronics Ltd

All position reports and unit status, type and names are stored in a
Microsoft® Access database included with SmartTRAC. This database will
grow as new polls are received. To keep the data secure and to keep the
database to a manageable size, it is recommended to archive the database
every month, or more frequently if required (depending on poll rate
number vehicles etc).

To archive a Database, a copy of a compression tool such as WinZip or
Power Archiver is valuable.

To archive the database and exchange with another, first locate the
database. Often it will be located under c:\program Files\SmartTRAC
and will be called StSample.mdb.

The next step assumes that a clean database was archived when the
package was installed.

Zip 'StSample.mdb’ and copy to a safe place. This database will contain a
month of position information for your vehicles. When zipping the
database it is useful to give the .zip file a meaningful name such as
june05.zip. This will also help prevent existing archived databases being
overwritten if the same name is used.

Unzip the clean copy of the database and place back into the folder where
the original database was copied. SmartTRAC now needs to know which
database to use. Use the following procedure to point SmartTRAC to the
correct database:

Run Start>Programs - SmartTRAC - ODBC Configuration
Select the ‘SmartTRAC’ User Datasource and click Configure
Click the Select button

Locate the ‘StSample’ database file (your database file may be named
differently) on the network fileserver and click ‘OK’

5. Click 'OK’ to close the remaining dialog boxes

AN =

If an error message “ODBC Microsoft Access Driver Login Failed — Could
not find the file ‘c:\program files\SmartTRAC\stsample.mdb” occurs, the
clean database has been installed into the wrong folder or has been
renamed. Repeat the above process making sure you are using the correct
database.

Telephone:+64-3-357-9991
support@taitworld.com
http://support.taitworld.com

TN-1063-AN-d.doc

Date of Print: 01/03/06 Page 28 of 30



Tait Confidential

Diagnostics

Tait Electronics Ltd

Vehicle Poll Status

SmartTRAC will display a unit status next to each vehicle. If this cannot be
seen, right click in the vehicles window and then select View->Details.

There are four possible states that are displayed next to each vehicle:

1. On - Normal: The vehicle is being polled successfully, a valid position
fix is being returned.

2. On - No GPS coverage: The radio is responding but the GPS unit
cannot obtain a valid position. The vehicle could be in a garage or in a
position where the GPS receiver does not have a clear view of the sky.

3. On - GPS Disconnected: The radio is responding but there is no
information to the radio from the GPS. The GPS receiver is either
unplugged from the radio or not functioning correctly.

4. Off / Not Home: The radio cannot be reached. The radio is either
switched off, or out of system coverage.

These states are logged into the database. If a problem occurs when
vehicles are polled, the database can be zipped up and sent away for
analysis. See Housekeeping for the details on how to zip and replace a
database.

Displaying the Map27 analyser

SmartTRAC MPT1327 versions have a Map27 packet analyser available.
This will show the Map27 commands between the radio and the PC.
Map27 is the data protocol used for MPT1327 radios.

To enable the packet analyser Choose Tools=>Communications
Properties.

Click on the radio tab and in the field called MAP27 trace code type in
log’. Click apply and the analyser will appear. This window will remain
open, even after SmartTRAC has been restarted. To stop this window from
appearing remove ‘log’ from this field and click apply.

To copy a view of the analyser to another application, select <alt> and
<print scrn> to copy it to the clipboard.
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7. Related Documentation

Compliance Issues

CSO Instruction

- TN-842-AN Direct connect GPS operation with the TM8100
- SmartTRAC users reference manual

- M2000-00-301 (T2000 service manual)

- MM8100-02-00-812 (TM8100 service manual

- MMA-00012-02 (TM8000 accessories manual)

None.

Please distribute to dealers and customers that need to configure an AVL
system using Tait radios and SmartTRAC tracking software.
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